Mail kann in OWA nicht gelöscht werden 22. März 2012

Neulich bekam ich eine Supportanfrage von einem befreundeten Systemhaus, dass sie bei einem Kunden ein relativ komisches Phänomen haben. Wenn Benutzer auf das eigene Postfach über Outlook Web Application zugreifen, dann können sie keine E-Mails verschieben oder löschen. Jeder Versuch dies zu tun, wird mit einer Fehlermeldung im OWA quittiert.

Diese Fehlermeldung ist erst einmal nichtssagend. Der nächste Blick ging in das Ereignisprotokoll des entsprechenden Servers. Dort findet man eine Fehlermeldung mit der EventID 108 und der Quelle “MSExchange OWA”. Als Fehlertext bekommt man “Outlook Web App konnte aufgrund eines Konfigurationsfehlers keine Verbindung zu den Exchange-Webdiensten herstellen. Antwortcode= ‘null, webExceptionStatus = SendFailure’.

Leider wird man aus dieser Fehlermeldung auch nicht unbedingt schlauer. Wenn man Google mit dieser Event-ID füttert, dann kommt eine Vielzahl von Ergebnissen. Ein Ergebnis zeigt auf folgenden KB-Artikel:

http://support.microsoft.com/kb/2249852

Allerdings trifft dieser Artikel nicht zu und das System war auch aktuell gepatcht. Als Nächstes gingen meine Gedanken in Richtung IIS. Ich habe mir also einmal die Konfiguration der Website angesehen. Genau dort bin ich fündig geworden. Der Kunde hatte auf diesem Server noch weitere Webseiten im IIS Konfiguriert. Damit das funktioniert, hatte er die “Default Web Site” fest an eine IP gebunden und die anderen Webseiten mit einem Hostheader konfiguriert. Die Bindungen für die “Default Web Site” sahen in etwa so aus:

Genau darüber stolpert Outlook Web App. Nachdem die Einstellungen korrigiert wurden, funktionierte Outlook Web App wieder wie gewohnt.

Lessons learned: Niemals an den Bindungen der Exchange Website fummeln und andere Webseiten haben im IIS des Exchange Servers nichts zu suchen. Leider war dieses System ein SBS 2011, wo schon durch die Installation mehrere Webseiten eingerichtet werden.

 

Leave a Reply

*